読者です 読者をやめる 読者になる 読者になる

bcrypt-rubyのGemがインストールできねえ

bcrypt-rubyのインストールでこけた。

Gem::RemoteFetcher::FetchError: Errno::ENETUNREACH: Network is unreachable - connect(2) (https://rubygems.org/gems/bcrypt-ruby-3.1.2.gem)

An error occurred while installing bcrypt-ruby (3.1.2), and Bundler cannot continue.

Make sure that `gem install bcrypt-ruby -v '3.1.2'` succeeds before bundling.

 

$ gem install bcrypt -v '3.1.9'

ERROR:  While executing gem ... (ArgumentError)

    malformed format string - %)

 

$ gem install bcrypt

ERROR:  While executing gem ... (ArgumentError)

    malformed format string - %)

 

関係ありそうなやつ

bcrypt gem がインストールできない場合の対処法 | ミラボ

Mac OS X Mavericks にアップデートしたら bcrypt-ruby gem がインストールできなくなったときの対処法 - 僕は発展途上技術者

 

$ brew update

$ brew install apple-gcc42

$ sudo ln -s /usr/local/bin/gcc-4.2 /usr/bin/gcc-4.2

$ bundle instal

Gem::RemoteFetcher::FetchError: Errno::ETIMEDOUT: Operation timed out - connect(2) (https://rubygems.org/gems/bcrypt-3.1.9.gem)

An error occurred while installing bcrypt (3.1.9), and Bundler cannot continue.

Make sure that `gem install bcrypt -v '3.1.9'` succeeds before bundling.

イェイ。

 

もう全然わかんねえ。

みんなこんなめんどくさい思いしながらがんばってるの?

それとも私だけがアレなの?

 

$ gem install rubygems-update

ERROR: While executing gem … (ArgumentError) | 42

CSS - Compassが入らなくて困った - Qiita

$ gem install ~/rubygems-update-2.4.5.gem

Successfully installed rubygems-update-2.4.5

1 gem installed

 

$ gem update --system

Updating rubygems-update

ERROR:  While executing gem ... (Gem::SpecificGemNotFoundException)

    Could not find a valid gem 'rubygems-update' (2.4.5) locally or in a repository

 なんか壊した感じがするぞ。

 

ruby - Cannot access to rubygems.org from terminal - Stack Overflow

bcryptがどうこうじゃないのかこれは。

 

$ rvm reinstall 2.0.0-p598 --with-openssl-dir=~/.rvm/usr

根が深そう。

 

RubyGems インストールできない プロキシ - Labo Memo

gem updateができない-certificate verify failed - リア充爆発日記

 

一回全部捨ててみるhoukou 

deikimasu

.

 

パソコン再起動して

$ bundle install で通りました。

なんだそりゃ。